perlbrew 0.65をMac(Mountain Lion)でインストールしようとするとおかしな挙動をする

  • patchperlとかいうやつのインストールに失敗している
  • インストールスクリプト実行後perlbrew install-patchperlとかやっても同じメッセージが出るだけで失敗する
  • 調査したところ、perlbrewのhttp_user_agent_commandとかいうサブルーチンがおかしな値を返却しているせいでまともに動かなくなっているっぽい
  • とりあえず0.65を動かすのを諦めて、古いバージョンを使うことにして解決した
    • インストールスクリプトのPERLBREWURLを書き換えて古いバージョンに向けさせた
  • plenvとかいうやつに移行しても良いかもしれない